EFI Partition gelöscht

BUTTON_POST_REPLY [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
snowman
Neuling
BeiträgeCOLON 6
RegistriertCOLON Sonntag 12. Oktober 2008, 17:31
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

EFI Partition gelöscht

Beitrag von snowman » Montag 3. November 2008, 18:25

Nach ersten Gehversuchen mit Linux habe ich bei einer Neuinstallation dummerweise die EFI Partition gelöscht. Weiß einer wie man die wiederherstellen kann? Partitionssuchprogramme bringen nichts mehr, da ich nach dem Motto wen schon denn schon auch neu Partitioniert habe :(

Benutzeravatar
k0k0
Power User
BeiträgeCOLON 1091
RegistriertCOLON Mittwoch 2. Juli 2008, 09:55
WohnortCOLON Graz
CONTACTCOLON

Re: EFI Partition gelöscht

Beitrag von k0k0 » Montag 3. November 2008, 19:46

Nimm ein Partitonierungsprogramm, lege auf der ersten Festplatte eine primäre Partition im Umfang von einem Zylinder an (meist sind das 8 MiB), formatiere das Ding mit FAT und versieh es anschließend mit der Partitionskennung für EFI-Partitionen (die hex-Zahl dafür ist 0xEF) und markiere die Partition als versteckt. Wundere Dich allerdings nicht, wenn Du etwas suchen musst, bis Du ein entsprechendes Programm dafür findest. Nicht alle Partitionierer können das. Macht aber auch nichts, denn die EFI-Partition wird bei den EeePCs nur für den BootBooster genutzt und ist daher prinzipiell entbehrlich. Lediglich der Bootvorgang dauert dann eben etwa 5 Sekunden länger. Andererseits kommt man ohne den BootBooster wesentlich einfacher ins BIOS und hat weniger Sorgen und Probleme beim Anlegen und Einspielen von Images.
Zuletzt geändert von 1 am k0k0, insgesamt 0-mal geändert.
Downloads zu Netbooks (wie den ASUS EeePCs, Acer Aspire One's) und vielem anderen
701 / 901(GO) / 1000HG(O) & Leeenux / WXP - 2 GiB RAM - 16 GB SDHC - Huawei E220 & EM770 / ZTE MF628

firehorse
Neuling
BeiträgeCOLON 33
RegistriertCOLON Mittwoch 24. Dezember 2008, 02:57
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: EFI Partition gelöscht

Beitrag von firehorse » Samstag 24. Januar 2009, 03:25

Verspätet aber immer noch besser als nichts.

Diese Partiton wird automatisch erstellt von der ASUS -Installation-DVD. Frage mich was Du unter Linux mit dieser willst? :)

Dürftest mittlerweile aber auch schon selbst herausgefunden haben. Nicht das ein unerfahrener User dem Thread meines Vorschreibers folgt. Das könnte fatale Folgen haben. Im übrigen macht das Partition Magic oder auch Ranish-Partitionsmanager. Hiermit kann man Partitionen erstellen, verstecken usw.. allerdings nur für Leute die Wissen was Sie tun ;)

gruß
firehorse

Benutzeravatar
freak1704
Mehrmalsposter
BeiträgeCOLON 88
RegistriertCOLON Donnerstag 1. Januar 2009, 12:31
WohnortCOLON 127.0.0.1
CONTACTCOLON

Re: EFI Partition gelöscht

Beitrag von freak1704 » Montag 26. Januar 2009, 20:00

Habe mehrere Anleitungen für das Wiederherstellen der EFI-Partition im Netz gefunden. Die Einrichtung der 8MB-Partition am Ende der SSD war mit Partition Magic kein Problem, jedoch kann Partition Magic der Partition nicht den Typ EFI zuweisen.

Nach einigen Versuchen mit Parted Magic und TestDisk habe ich es zwar geschafft, die Partition auf EFI umzustellen, mir dabei jedoch den MBR zerschossen, was weitere Versuche mit einer WinPE-Disk nach sich zog. :(

Von daher kann ich nur warnen: beim Basteln am Dateisystem kann man sich ruckzuck sein ganzes System schrotten, wenn man nicht genau weiß, was man da tut!

Die einfachste Möglichkeit, die EFI-Partition wiederherszustellen ist ein Neuaufsetzen des Systems mit der Recovery-DVD, welche die EFI-Partition automatisch erstellt.
Die EU-Bildungsminister warnen:
Lesen gefährdet Ihre Dummheit!



Eee PC 901 GO in perlweiß mit schönem Skin von skins4u.de, 2GB RAM, XP Pro SP3 Darkside Edition, 32GB RunCore SSD und web'n'walk Connect L SIM-Karte

Benutzeravatar
vofiwg
Power User
BeiträgeCOLON 2079
RegistriertCOLON Donnerstag 22. November 2007, 19:36
CONTACTCOLON

Re: EFI Partition gelöscht

Beitrag von vofiwg » Montag 26. Januar 2009, 21:47

Ihr redet hier über Linux, Xandros vielleicht sogar?

Hat das schon mal jemand versucht mit dem Programm cfdisk?

Bei mir kann man mit cfdisk den Typ einer Partition auf EF EFI (FAT-12/16/32) einstellen. Das sollte doch wohl die gesuchte EFI-Partition sein!?


VoFiWG
Meine Tipps und Hinweise gibt es unter Ausschluss jeglicher Gewährleistung aber mit ganz dollem Daumendrücken. ;)

Benutzeravatar
freak1704
Mehrmalsposter
BeiträgeCOLON 88
RegistriertCOLON Donnerstag 1. Januar 2009, 12:31
WohnortCOLON 127.0.0.1
CONTACTCOLON

Re: EFI Partition gelöscht

Beitrag von freak1704 » Montag 26. Januar 2009, 22:30

Jein. ;)

Da die EFI Partition ja sowohl unter Linux als auch unter Window$ den BootBooster ermöglicht, ist das Betriebssystem eigentlich egal.

In meinem Fall kann ich sagen: habe XP Pro auf dem Eee und Partition Magic als DOS Bootdisk und Parted Magic als Live-Linux laufen gehabt. WinPE erklärt sich ja selbst... ;)
Die EU-Bildungsminister warnen:
Lesen gefährdet Ihre Dummheit!



Eee PC 901 GO in perlweiß mit schönem Skin von skins4u.de, 2GB RAM, XP Pro SP3 Darkside Edition, 32GB RunCore SSD und web'n'walk Connect L SIM-Karte

Benutzeravatar
vofiwg
Power User
BeiträgeCOLON 2079
RegistriertCOLON Donnerstag 22. November 2007, 19:36
CONTACTCOLON

Re: EFI Partition gelöscht

Beitrag von vofiwg » Montag 26. Januar 2009, 22:35

Wenn man mit parted magic die (FAT)Partition anlegt und anschließend mit fdisk oder cdfisk den Partitionstyp ändert, sollte das auch ohne Wiederherstellung laufen.


VoFiWG
Meine Tipps und Hinweise gibt es unter Ausschluss jeglicher Gewährleistung aber mit ganz dollem Daumendrücken. ;)

snowman
Neuling
BeiträgeCOLON 6
RegistriertCOLON Sonntag 12. Oktober 2008, 17:31
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: EFI Partition gelöscht

Beitrag von snowman » Donnerstag 5. Februar 2009, 21:58

Ich habe damals einfach des Backup von Asus eingespielt und dann nochmal Debian draufgepakt. Hat super geklappt!

Benutzeravatar
freak1704
Mehrmalsposter
BeiträgeCOLON 88
RegistriertCOLON Donnerstag 1. Januar 2009, 12:31
WohnortCOLON 127.0.0.1
CONTACTCOLON

Re: EFI Partition gelöscht

Beitrag von freak1704 » Sonntag 8. Februar 2009, 18:22

Ja, ein Recovery ist die einfachste Lösung, die EFI-Partition wiederherzustellen, falls man sich von seinem aktuellen System trennen kann.

Und ja, der BootBooster macht schon einiges an Bootgeschwindigkeit aus.

Wenn ich jetzt noch eine idiotensichere Anleitung für den Austausch der Winlogon.exe durch die Minlogon.exe und evtl. EWF.sys finde, rennt das Ding aus dem ausgeschalteten Zustand fast so schnell wie aus dem Standby nach Windows. :wink:

Irgendwo hatte jemand ein Video verlinkt, in dem vom Einschalten des Eee bis zum Start der ersten Anwendung 26 Sekunden vergingen. Wow!
Die EU-Bildungsminister warnen:
Lesen gefährdet Ihre Dummheit!



Eee PC 901 GO in perlweiß mit schönem Skin von skins4u.de, 2GB RAM, XP Pro SP3 Darkside Edition, 32GB RunCore SSD und web'n'walk Connect L SIM-Karte

Benutzeravatar
k0k0
Power User
BeiträgeCOLON 1091
RegistriertCOLON Mittwoch 2. Juli 2008, 09:55
WohnortCOLON Graz
CONTACTCOLON

Re: EFI Partition gelöscht

Beitrag von k0k0 » Mittwoch 22. September 2010, 17:20

Die EFI-Partition muss lediglich einen Zylinder umfassen (das sind meist 8 MiB) und kann, wie schon im Beitrag davor erwähnt, mit jeder Linux-Live-Distri angelegt werden. Anfänger erledigen das Anlegen einer Partition am einfachsten mit einem Programm namens gparted das eine recht übersichtliche GUI hat, und in nahezu jeder Live-Distri enthalten ist. Damit legt man erst einmal die benötigte primäre Partition (z.B. vom Typ FAT) von maximal 8 MiB an und wählt bei der Frage nach dem Dateisystem "nicht formatieren" (letzter Punkt des entsprechenden Menüs) aus. Nachdem dieser Teil erledigt ist, müssen wir nur noch den Partitionstyp auf 0xEF ändern. BTW: Es ist einerlei, an welcher Stelle der Festplatte die EFI-Partition angelegt wird; ob am Beginn, am Ende oder gar in der Mitte der Festplatte macht keinen Unterschied. Üblich ist wohl am Ende oder am Beginn.

Dazu öffnet man ein Terminal / die Konsole (also so etwas ähnliches wie CMD.EXE unter Windows bzw. das Prompt unter DOS) und ruft das Programm fdisk, eventuell mit Administratorrechten (also mit sudo oder su) auf. Dann lässt man sich mit fdisk -l die Partitionen anzeigen und macht dann mit der ersten Festplatte weiter, in dem man fdisk gefolgt vom Device (~der Festplatte) eingibt. Meist lautet das vollständige Kommando dann fdisk /dev/sda. (Unter Linux werden die vorhanden Festplatten mit a beginnend "nummeriert".)

Als nächsten Schritt gibt man nun t (für toggle) ein und wählt die vorhin angelegte winzige Partition aus, in dem man die entsprechende Zahl eintippt. Anschließend brauchen wir nur noch ef (für den gewünschten Partitionstyp 0xEF) angeben und die Änderungen mit w (für write) speichern. Das Programm verlassen wir mit q (für quit) und die Konsole schließen wir mit exit.

Fertig ist die EFI-Partition. Nach deren Nutzungsaktivierung im BIOS und ab dem zweiten Bootvorgang kommt man in den Genuss eines etwas schnelleren Systemstarts, weil manche Punkte der BIOS-"Tests" (wie z.B. der Test des installierten RAM) übersprungen werden.

Die Profis können natürlich auch die benötigte primäre Partition mit fdisk anlegen und ersparen sich so den Aufruf eines weiteren Programmes.
Downloads zu Netbooks (wie den ASUS EeePCs, Acer Aspire One's) und vielem anderen
701 / 901(GO) / 1000HG(O) & Leeenux / WXP - 2 GiB RAM - 16 GB SDHC - Huawei E220 & EM770 / ZTE MF628

Benutzeravatar
iceWM
Administrator
BeiträgeCOLON 3401
RegistriertCOLON Samstag 17. Mai 2008, 16:58
WohnortCOLON NRW - D - Erde - Sonnensystem - Milchstraße - Lokale Gruppe - Universum
CONTACTCOLON

Re: EFI Partition gelöscht

Beitrag von iceWM » Mittwoch 22. September 2010, 21:51

Willkommen zurück k0k0 :)

Dein Beitrag würde auch gut zu den How2s passen.
Ich würde ihn ja dorthin verschieben, dann fehlt er aber hier und das wäre schade.
Forums-Samariter
RTFM und auch die Hilfe des Programms...
eeePC 901/1000H/XP/W/1024 MB/T91 Bk W7 HP/1201NL Bk W7 HP
Mein Blog / Never Ending Quiz / FAQ
Wenn Euer Problem gelöst wurde, setzt bitte ein [Gelöst] vor den Threadtitel.
Danke!

BUTTON_POST_REPLY
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Zurück zu

Wer ist online?

Mitglieder in diesem Forum: 1 und 0 Gäste