Externe USB-Soundkarte unter Linpus?

Allgemeine Fragen zu Linux
ompfi
Neuling
BeiträgeCOLON 6
RegistriertCOLON Sonntag 21. Juni 2009, 08:42

Externe USB-Soundkarte unter Linpus?

Beitrag von ompfi » Sonntag 21. Juni 2009, 10:15

Hallo und guten Tag! Ich will an das Aspire One A110L eine externe USB-Soundkarte (Creative X-Fi Surround 5.1) anschließen und bin Anfänger bzgl. Linux/Linpus. Mittlerweile habe ich es geschafft, dass amarok meine mp3-Dateien abspielt. Ich habe allerdings nicht die mindeste Ahnung, wie ich Linpus dazu kriege, die externe USB-Soundkarte zu erkennen, geschweige sie irgendwann einmal in amarok auswählen zu können. Kann mir jemand die notwendigen Schritte beibringen, bzw. hat das jemand unter Linpus schon hinbekommen? Unter http://www.loth.de/ueber-uns/technik-bl ... ieren.html habe ich zwar eine Hilfe zur Konfiguration einer USB-Soundkarte unter Linux gefunden, aber in Linpus kann ich diese Anleitung einfach nicht erfolgreich umsetzen. Für nutzbringende Hinweise im Voraus vielen, vielen Dank! Ompfi

Benutzeravatar
blackice
Power User
BeiträgeCOLON 1079
RegistriertCOLON Dienstag 11. November 2008, 21:46

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von blackice » Sonntag 21. Juni 2009, 17:08

Kannst du mal bitte die Ausgabe von lsusb bei angesteckter USB-Soundkarte posten?
Modell: EEE 901 - OS: wattOS beta1 (array.org-kernel)/Slax 6.0.7 (alsa 1.0.18a) - RAM: 2GB (MDT 667MHz) - Zubehör: Akku 8800mAh, SDHC-Card Sandisk UltraII plus USB 8GB

ompfi
Neuling
BeiträgeCOLON 6
RegistriertCOLON Sonntag 21. Juni 2009, 08:42

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von ompfi » Montag 22. Juni 2009, 12:10

Hier kommt sie:
[user@localhost ~]$ lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 041e:3042 Creative Technology, Ltd
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 046d:c402 Logitech, Inc. Marble Mouse (2-button)
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 064e:d101 Acer Crystal Eye Webcam
Bus 001 Device 002: ID 13fe:1d00
Bus 001 Device 001: ID 0000:0000
[user@localhost ~]$

Ompfi.

Benutzeravatar
blackice
Power User
BeiträgeCOLON 1079
RegistriertCOLON Dienstag 11. November 2008, 21:46

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von blackice » Montag 22. Juni 2009, 14:09

Dein Alsa ist zu alt, dort wird die Karte noch nicht unterstützt.
Der schnellste Weg dem beizukommen wäre, die Quellen der aktuellen Alsa-Version von alsa-project.org herunterzuladen und neu zu kompilieren.
Der einfachere Weg wäre, eine Distribution mit aktuellerem Alsa zu installieren.

Außerdem ist fraglich ob das passende Kernelmodul geladen ist. Was ergibt lsusb als root?
Modell: EEE 901 - OS: wattOS beta1 (array.org-kernel)/Slax 6.0.7 (alsa 1.0.18a) - RAM: 2GB (MDT 667MHz) - Zubehör: Akku 8800mAh, SDHC-Card Sandisk UltraII plus USB 8GB

ompfi
Neuling
BeiträgeCOLON 6
RegistriertCOLON Sonntag 21. Juni 2009, 08:42

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von ompfi » Montag 22. Juni 2009, 15:08

Das ergibt nichts (??):

[user@localhost ~]$ sudo bash
[root@localhost ~]# lsusb
bash: lsusb: command not found
[root@localhost ~]#

Gruß Ompfi

Benutzeravatar
vofiwg
Power User
BeiträgeCOLON 2079
RegistriertCOLON Donnerstag 22. November 2007, 19:36
CONTACTCOLON

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von vofiwg » Montag 22. Juni 2009, 15:21

Hast Du ISUSB (kleingeschrieben) oder LSUSB (kleingeschrieben) eingegeben? Der erste Buchstabe des Befehles muss ein kleines L sein.

Der Befehl ist ganz sicher vorhanden.



VoFiWG
Meine Tipps und Hinweise gibt es unter Ausschluss jeglicher Gewährleistung aber mit ganz dollem Daumendrücken. ;)

ompfi
Neuling
BeiträgeCOLON 6
RegistriertCOLON Sonntag 21. Juni 2009, 08:42

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von ompfi » Montag 22. Juni 2009, 16:06

Ich wollte es zunächst auch nicht glauben, habs nun aber noch mal nach nem Neustart bestätigt: es kommt nichts Anderes, ich hab alles klein geschrieben.
Ompfi

Benutzeravatar
blackice
Power User
BeiträgeCOLON 1079
RegistriertCOLON Dienstag 11. November 2008, 21:46

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von blackice » Montag 22. Juni 2009, 16:19

lsusb - Blödsinn! Das hatten wir ja schon. :oops:
Ich meinte lsmod.

Vor dem Alsa-Update ist das aber eigentlich uninteressant.
Modell: EEE 901 - OS: wattOS beta1 (array.org-kernel)/Slax 6.0.7 (alsa 1.0.18a) - RAM: 2GB (MDT 667MHz) - Zubehör: Akku 8800mAh, SDHC-Card Sandisk UltraII plus USB 8GB

ompfi
Neuling
BeiträgeCOLON 6
RegistriertCOLON Sonntag 21. Juni 2009, 08:42

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von ompfi » Montag 22. Juni 2009, 16:40

Okay hier ist lsmod, als root kam aber wieder nix. Ich werde mich dann mal um alsa kümmern. Hab zwar keine Ahnung, was da auf mich zukommt und wie das zu bewerkstelligen ist. Werde sicher ein paar Tage brauchen bis ich mich durchgekämpft habe. Muss ich all diese Bestandteile installieren?

* alsa-driver-1.0.20
* alsa-lib-1.0.20
* alsa-utils-1.0.20
* alsa-tools-1.0.20
* alsa-firmware-1.0.20
* alsa-plugins-1.0.20
* alsa-oss-1.0.17
* pyalsa-1.0.20


[user@localhost ~]$ lsmod
Module Size Used by
aufs 95956 3
wlan_tkip 8384 3
wlan_ccmp 4480 0
wlan_xauth 640 0
wlan_wep 3904 0
wlan_acl 2048 0
wlan_scan_sta 7232 1
fastoffdrv 768 0 [permanent]
sdhci 9292 0
mmc_core 14852 1 sdhci
pciehp 22232 0
pci_hotplug 7688 1 pciehp
cpufreq_conservative 3080 0
cpufreq_userspace 1388 0
cpufreq_powersave 640 0
cpufreq_stats 2256 0
cpufreq_ondemand 3532 1
acpi_cpufreq 3604 1
freq_table 1608 3 cpufreq_stats,cpufreq_ondemand,acpi_cpufreq
jmb38x_xd 3776 0
xd_card 18696 1 jmb38x_xd
flash_bd 5056 1 xd_card
mspro_block 20424 0
jmb38x_ms 4484 0
memstick 4484 2 mspro_block,jmb38x_ms
usbhid 16320 0
snd_hda_intel 163404 0
fmaud 142820 1 snd_hda_intel
snd_seq_oss 20160 0
snd_seq_midi_event 3008 1 snd_seq_oss
snd_seq 27920 4 snd_seq_oss,snd_seq_midi_event
uvcvideo 39752 0
snd_seq_device 3468 2 snd_seq_oss,snd_seq
compat_ioctl32 640 1 uvcvideo
videodev 20928 1 uvcvideo
v4l1_compat 10500 2 uvcvideo,videodev
v4l2_common 10688 2 uvcvideo,videodev
ath_pci 68192 0
rng_core 2180 0
snd_pcm_oss 26208 0
ath_rate_atheros 23424 1 ath_pci
video 10896 0
wlan 126744 9 wlan_tkip,wlan_ccmp,wlan_xauth,wlan_wep,wlan_acl,wlan_scan_sta,ath_pci,ath_rate_atheros
backlight 1860 1 video
thermal 8092 0
snd_pcm 41028 2 snd_hda_intel,snd_pcm_oss
ath_dfs 25796 1 ath_pci
output 1280 1 video
ac 2116 0
battery 6472 0
button 3536 0
processor 18624 2 acpi_cpufreq,thermal
ath_hal 147200 3 ath_pci,ath_rate_atheros
r8101 16400 0
snd_timer 11012 2 snd_seq,snd_pcm
uhci_hcd 13644 0
snd_page_alloc 4168 2 snd_hda_intel,snd_pcm
snd_mixer_oss 9856 1 snd_pcm_oss
snd 27236 8 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore 2976 1 snd
usb_storage 34656 0
ehci_hcd 20300 0
atkbd 8912 0
psmouse 13320 0
[user@localhost ~]$

... und noch mal vielen Dank für die schnellen Hinweise hier im Board. Ompfi.

Benutzeravatar
blackice
Power User
BeiträgeCOLON 1079
RegistriertCOLON Dienstag 11. November 2008, 21:46

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von blackice » Dienstag 23. Juni 2009, 07:42

Die Kernelmodule für USB-Soundkarten sind nicht geladen.
Das geht als root so (in Linpus mit sudo?):

CodeCOLON Alles auswählen

modprobe snd-usb-audio
modprobe snd-usb-lib
Danach sollte deine USB-Soundkarte funktionieren, wenn Alsa sie unterstützt.

Zum Update von Alsa brauchst du nur diese drei Pakete:
* alsa-driver-1.0.20
* alsa-lib-1.0.20
* alsa-utils-1.0.20

Am besten speicherst du sie in ein Extraverzeichnis.

Zusätzlich brauchst du noch die Kernel-Headers deines Kernels. Falls Linpus die bereit stellt findest du die über den Paketmanager mit

CodeCOLON Alles auswählen

yum search linux-headers-$(uname -r)
und kannst sie so installieren

CodeCOLON Alles auswählen

yum install linux-headers-$(uname -r)
Dann entpackst du die Alsa-Pakete:

CodeCOLON Alles auswählen

tar -xjf alsa-driver-1.0.20.tar.bz2
tar -xjf alsa-lib-1.0.20.tar.bz2
tar -xjf alsa-utils-1.0.20.tar.bz2
Es gibt jetzt jeweils ein Verzeichnis jedes Pakets. Dorthin wechselst du und kompilierst die Pakete in der oben angegebenen Reihenfolge (wichtig) mit dem üblichen Dreisatz:

CodeCOLON Alles auswählen

./configure
make
make install
Ich weiß nicht ob es nötig ist, aber im Verzeichnis des Alsa-driver-Codes befindet sich ein Executable namens

CodeCOLON Alles auswählen

snddevices
Dieses führst du aus.

Unter Slax musste ich dann noch

CodeCOLON Alles auswählen

options snd-hda-intel model=auto
in die Datei /etc/modprobe.d/alsa-base eintragen. Falls die Datei nicht existiert, erstelle sie.

Bei dir muss der Inhalt vermutlich aber so aussehen:

CodeCOLON Alles auswählen

options snd-usb-audio model=auto
Das ist jetzt nur aus dem Gedächtnis. Falls ich die Zeit finde, werde ich das ganze Prozedere mal in einer Linpus-VM testen.
Modell: EEE 901 - OS: wattOS beta1 (array.org-kernel)/Slax 6.0.7 (alsa 1.0.18a) - RAM: 2GB (MDT 667MHz) - Zubehör: Akku 8800mAh, SDHC-Card Sandisk UltraII plus USB 8GB

Benutzeravatar
flux
ENTWICKLER
BeiträgeCOLON 355
RegistriertCOLON Donnerstag 20. März 2008, 16:38

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von flux » Dienstag 23. Juni 2009, 10:48

Ich würde das firmware-Paket auch mit dazu nehmen, da bestimmte Soundkarten sonst nicht mehr gehen ...

flux.

Benutzeravatar
flux
ENTWICKLER
BeiträgeCOLON 355
RegistriertCOLON Donnerstag 20. März 2008, 16:38

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von flux » Dienstag 23. Juni 2009, 11:10

Bei mir listet ein

CodeCOLON Alles auswählen

modinfo snd-usb-audio
mit Alsa 1.0.20 nur die ID
alias: usb:v041Ep3048d*dc*dsc*dp*ic*isc*ip*
Auch im heutigen Snapshot ist die ID nicht gelistet ... allerdings gibt es wohl eine analoge Soundkarte in PCI-Ausführung, die in ALSA unterstützt wird (snd-ctxfi) ...

flux.

ompfi
Neuling
BeiträgeCOLON 6
RegistriertCOLON Sonntag 21. Juni 2009, 08:42

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von ompfi » Dienstag 23. Juni 2009, 16:55

So, nun hab ich´zur Sicherheit noch mal von ganz von vorne angefangen, d.h das System neu aufgespielt und dann versucht, Eure Hinweise umzusetzen.

modprobe snd-usb-audio und modprobe snd-usb-lib kennt er nicht:

[user@localhost home]$ sudo su
[root@localhost home]# modprobe snd-usb-audio
bash: modprobe: command not found
[root@localhost home]# modprobe snd-usb-lib
bash: modprobe: command not found
[root@localhost home]#


Zu yum search linux-headers-$(uname -r) und yum install linux-headers-$(uname -r) gibt es ebenfalls nichts Passendes:

[user@localhost home]$ sudo su
[root@localhost home]# yum search linux-headers-$(uname -r)
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.6 kB 00:00
No Matches found
[root@localhost home]# yum install linux-headers-$(uname -r)
Setting up Install Process
Parsing package install arguments
No package linux-headers-2.6.23.9lw available.
Nothing to do
[root@localhost home]#


und die alsa-Dateien will er nicht kompilieren:

[user@localhost alsa-driver-1.0.20]$ sudo su
[root@localhost alsa-driver-1.0.20]# ./configure
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
[root@localhost alsa-driver-1.0.20]#

Ich denke, mein Anliegen an Linpus ist wohl zu hoch. Keine Ahnung, ob ich nach wochenlangem Tüfteln dazu kommen könnte, die USB-Soundkarte unter Linpus doch noch zum Laufen zu bekommen. Meine Absicht war, mit dem kleinen Aspire One meine große Hifi-Anlage zu steuern. Die für die Nachprogrammierung aufzuwendende Zeit erscheint mir aber nicht mehr verhältnismäßig. Ich habs probiert und ihr habt mich super dabei unterstützt, trotzdem will es nicht funzen. Muss ich mir für meine Anlage was andres einfallen lassen. Danke noch mal ... Ompfi

Benutzeravatar
blackice
Power User
BeiträgeCOLON 1079
RegistriertCOLON Dienstag 11. November 2008, 21:46

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von blackice » Dienstag 23. Juni 2009, 19:47

Das Einfachste wäre wohl, du installierst eine andere Distribution.
Linpus basiert auf Fedora, was eine sehr aktuelle Distribution ist. Damit läuft die USB-Soundkarte vermutlich out of the box.
Und vielleicht erkennst du einige Dinge wieder.
Modell: EEE 901 - OS: wattOS beta1 (array.org-kernel)/Slax 6.0.7 (alsa 1.0.18a) - RAM: 2GB (MDT 667MHz) - Zubehör: Akku 8800mAh, SDHC-Card Sandisk UltraII plus USB 8GB

Benutzeravatar
vofiwg
Power User
BeiträgeCOLON 2079
RegistriertCOLON Donnerstag 22. November 2007, 19:36
CONTACTCOLON

Re: Externe USB-Soundkarte unter Linpus?

Beitrag von vofiwg » Dienstag 23. Juni 2009, 20:21

CodeCOLON Alles auswählen

sudo /sbin/modprobe
Man muss unter Linpus wohl den ganzen Pfad angeben. :)

Linpus scheint mir eine ähnliche Krücke zu sein, wie Xandros auf dem EeePC, was den "Ausbau" betrifft.. Will man da mal etwas machen, was über den Bereich Office/Internet/Einfach-Multimedia rausgeht, fängt die Bastelei an. :(


VoFiWG
Meine Tipps und Hinweise gibt es unter Ausschluss jeglicher Gewährleistung aber mit ganz dollem Daumendrücken. ;)

BUTTON_POST_REPLY

Zurück zu

Wer ist online?

Mitglieder in diesem Forum: 1 und 0 Gäste