Installations- und Deinstallationsüberschneidung

BUTTON_POST_REPLY
hvt
Mehrmalsposter
BeiträgeCOLON 93
RegistriertCOLON Samstag 15. November 2008, 20:29

Installations- und Deinstallationsüberschneidung

Beitrag von hvt » Dienstag 6. Januar 2009, 18:01

Hallo Leute!

Ich wollte mir die Open-Office Version anstatt der vorhandenen Star Office Version installieren (fragt mich nicht warum).
Jetzt hat sich irgendwie ein Abhängigkeitsproblem ergeben und ich habe die Open-Office Pakete im "Defekt"-Ordner drinnen. Wenn ich sie dort enfernen möchte erhalte ich folgende Fehlermeldung:


/bin/sh: line 1: 16588 Speicherzugriffsfehler /usr/sbin/dpkg-preconfigure --aptdpkg: Fehler beim Bearbeiten von openoffice.org-base (--remove):
Paket ist in einem sehr schlechten inkonsistenten Zustand - Sie sollten
es erneut installieren, bevor Sie es zu entfernen versuchen.
Fehler traten auf beim Bearbeiten von:
openoffice.org-base
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Richte kopete ein (3.4.2.25-1) ...
/var/lib/dpkg/info/kopete.postinst: line 20: 16596 Speicherzugriffsfehler update-alternatives --quiet --install /usr/share/services/irc.protocol irc.protocol /usr/share/apps/kopete/irc.protocol 40
dpkg: Fehler beim Bearbeiten von kopete (--configure):
Unterprozess post-installation script gab den Fehlerwert 139 zurück
Richte openoffice.org-base-core ein (2.4.0-4+eeepc1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von openoffice.org-style-andromeda:
openoffice.org-style-andromeda hängt ab von openoffice.org-common (= 1:2.4.0-4+eeepc1); aber:
Paket openoffice.org-common ist nicht installiert.
dpkg: Fehler beim Bearbeiten von openoffice.org-style-andromeda (--configure):
Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-uno:
python-uno hängt ab von openoffice.org-core (= 1:2.4.0-4+eeepc1); aber:
Paket openoffice.org-core ist nicht installiert.
dpkg: Fehler beim Bearbeiten von python-uno (--configure):
Abhängigkeitsprobleme - lasse es unkonfiguriert


Ich habe es auch mit sudo apt-get -f install versucht und erhalte folgende Meldung:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Abhängigkeit werden korrigiert... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
libneon26 openoffice.org-base openoffice.org-common openoffice.org-core
openoffice.org-draw openoffice.org-impress openoffice.org-java-common
openoffice.org-math openoffice.org-writer
Vorgeschlagene Pakete:
libmyodbc odbc-postgresql libsqliteodbc tdsodbc mdbtools libmysql-java
libpg-java libsapdbc-java openoffice.org-gcj openoffice.org-report-builder
openoffice.org-style-industrial openoffice.org-style-hicontrast
Empfohlene Pakete:
openoffice.org-style-tango openoffice.org-style-crystal
openoffice.org-filter-binfilter
Die folgenden NEUEN Pakete werden installiert:
libneon26 openoffice.org-common openoffice.org-core
openoffice.org-java-common
Die folgenden Pakete werden aktualisiert:
openoffice.org-base openoffice.org-draw openoffice.org-impress
openoffice.org-math openoffice.org-writer


Wenn ich mit "Ja" fortfahre, kommt:

5 aktualisiert, 4 neu installiert, 0 zu entfernen und 77 nicht aktualisiert.
8 nicht vollständig installiert oder entfernt.
Es müssen noch 0B von 76,4MB Archiven geholt werden.
Nach dem Auspacken werden 170MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
WARNUNG: Die folgenden Pakete können nicht authentifiziert werden!
openoffice.org-impress openoffice.org-draw openoffice.org-math
openoffice.org-writer openoffice.org-common libneon26 openoffice.org-base
openoffice.org-core openoffice.org-java-common

Weiter mit "Ja":

/bin/sh: line 1: 17869 Speicherzugriffsfehler /usr/sbin/dpkg-preconfigure --apt
(Lese Datenbank ... 85959 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereiten zum Ersetzen von openoffice.org-impress 2.0.4.dfsg.2-7etch2eeepc2 (durch .../openoffice.org-impress_1%3a2.4.0-4+eeepc1_i386.deb) ...
Entpacke Ersatz für openoffice.org-impress ...
/var/lib/dpkg/info/openoffice.org-impress.postrm: line 4: 17895 Speicherzugriffsfehler update-mime
dpkg: Warnung - altes post-removal-Skript wurde mit Fehler-Status 139 beendet
dpkg - probiere stattdessen Skript aus dem neuen Paket ...
/var/lib/dpkg/tmp.ci/postrm: line 4: 17898 Speicherzugriffsfehler update-mime
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/openoffice.org-impress_1%3a2.4.0-4+eeepc1_i386.deb (--unpack):
Unterprozess neues post-removal-Skript gab den Fehlerwert 139 zurück
/var/lib/dpkg/tmp.ci/postrm: line 4: 17901 Speicherzugriffsfehler update-mime
dpkg: Fehler beim Aufräumen:
Unterprozess post-removal script gab den Fehlerwert 139 zurück
Vorbereiten zum Ersetzen von openoffice.org-draw 2.0.4.dfsg.2-7etch2eeepc2 (durch .../openoffice.org-draw_1%3a2.4.0-4+eeepc1_i386.deb) ...
Entpacke Ersatz für openoffice.org-draw ...
/var/lib/dpkg/info/openoffice.org-draw.postrm: line 4: 17931 Speicherzugriffsfeh
ler update-mime
dpkg: Warnung - altes post-removal-Skript wurde mit Fehler-Status 139 beendet
dpkg - probiere stattdessen Skript aus dem neuen Paket ...
/var/lib/dpkg/tmp.ci/postrm: line 4: 17934 Speicherzugriffsfehler update-mime
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/openoffice.org-draw_1%3a2.4.0-4+eeepc1_i386.deb (--unpack):
Unterprozess neues post-removal-Skript gab den Fehlerwert 139 zurück
/var/lib/dpkg/tmp.ci/postrm: line 4: 17937 Speicherzugriffsfehler update-mime
dpkg: Fehler beim Aufräumen:
Unterprozess post-removal script gab den Fehlerwert 139 zurück
Vorbereiten zum Ersetzen von openoffice.org-math 2.0.4.dfsg.2-7etch2eeepc2 (durch .../openoffice.org-math_1%3a2.4.0-4+eeepc1_i386.deb) ...
Entpacke Ersatz für openoffice.org-math ...
/var/lib/dpkg/info/openoffice.org-math.postrm: line 4: 17965 Speicherzugriffsfehler update-mime
dpkg: Warnung - altes post-removal-Skript wurde mit Fehler-Status 139 beendet
dpkg - probiere stattdessen Skript aus dem neuen Paket ...
/var/lib/dpkg/tmp.ci/postrm: line 4: 17968 Speicherzugriffsfehler update-mime
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/openoffice.org-math_1%3a2.4.0-4+eeepc1_i386.deb (--unpack):
Unterprozess neues post-removal-Skript gab den Fehlerwert 139 zurück
/var/lib/dpkg/tmp.ci/postrm: line 4: 17971 Speicherzugriffsfehler update-mime
dpkg: Fehler beim Aufräumen:
Unterprozess post-removal script gab den Fehlerwert 139 zurück
Vorbereiten zum Ersetzen von openoffice.org-writer 2.0.4.dfsg.2-7etch2eeepc2 (durch .../openoffice.org-writer_1%3a2.4.0-4+eeepc1_i386.deb) ...
Entpacke Ersatz für openoffice.org-writer ...
/var/lib/dpkg/info/openoffice.org-writer.postrm: line 4: 18008 Speicherzugriffsfehler update-mime
dpkg: Warnung - altes post-removal-Skript wurde mit Fehler-Status 139 beendet
dpkg - probiere stattdessen Skript aus dem neuen Paket ...
/var/lib/dpkg/tmp.ci/postrm: line 4: 18011 Speicherzugriffsfehler update-mime
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/openoffice.org-writer_1%3a2.4.0-4+eeepc1_i386.deb (--unpack):
Unterprozess neues post-removal-Skript gab den Fehlerwert 139 zurück
/var/lib/dpkg/tmp.ci/postrm: line 4: 18015 Speicherzugriffsfehler update-mime
dpkg: Fehler beim Aufräumen:
Unterprozess post-removal script gab den Fehlerwert 139 zurück
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/openoffice.org-impress_1%3a2.4.0-4+eeepc1_i386.deb
/var/cache/apt/archives/openoffice.org-draw_1%3a2.4.0-4+eeepc1_i386.deb
/var/cache/apt/archives/openoffice.org-math_1%3a2.4.0-4+eeepc1_i386.deb
/var/cache/apt/archives/openoffice.org-writer_1%3a2.4.0-4+eeepc1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Irgendwie habe ich das Gefühl, dass sich da etwas überschneidet...

hvt
Mehrmalsposter
BeiträgeCOLON 93
RegistriertCOLON Samstag 15. November 2008, 20:29

Re: Installations- und Deinstallationsüberschneidung

Beitrag von hvt » Mittwoch 21. Januar 2009, 16:53

gibt es eine andere möglichkeit die pakete runterzubekommen? so eine art brachiallöschung?

Benutzeravatar
blackice
Power User
BeiträgeCOLON 1079
RegistriertCOLON Dienstag 11. November 2008, 21:46

Re: Installations- und Deinstallationsüberschneidung

Beitrag von blackice » Mittwoch 21. Januar 2009, 17:20

Versuch mal die Pakete manuell mit dpkg -P loszuwerden:

CodeCOLON Alles auswählen

dpkg -P /var/cache/apt/archives/openoffice.org-impress_1%3a2.4.0-4+eeepc1_i386.deb
dpkg -P /var/cache/apt/archives/openoffice.org-draw_1%3a2.4.0-4+eeepc1_i386.deb
dpkg -P /var/cache/apt/archives/openoffice.org-math_1%3a2.4.0-4+eeepc1_i386.deb
dpkg -P /var/cache/apt/archives/openoffice.org-writer_1%3a2.4.0-4+eeepc1_i386.deb
Das Ganze machst du als root.

Ob das reicht weiß ich nicht. Vermutlich wirst du zumindest auch das base-Paket noch entfernen müssen.
Ob weitere Abhängigkeiten betroffen sind, kann ich so auch nicht sagen.
Modell: EEE 901 - OS: wattOS beta1 (array.org-kernel)/Slax 6.0.7 (alsa 1.0.18a) - RAM: 2GB (MDT 667MHz) - Zubehör: Akku 8800mAh, SDHC-Card Sandisk UltraII plus USB 8GB

hvt
Mehrmalsposter
BeiträgeCOLON 93
RegistriertCOLON Samstag 15. November 2008, 20:29

Re: Installations- und Deinstallationsüberschneidung

Beitrag von hvt » Freitag 30. Januar 2009, 15:32

hallo blackice!

vielen dank, hat leider nicht ganz geklappt...F9 hat mir wieder einmal geholfen :?

BUTTON_POST_REPLY

Zurück zu

Wer ist online?

Mitglieder in diesem Forum: 2 und 0 Gäste