.net framework

BUTTON_POST_REPLY [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
Gecko
Neuling
BeiträgeCOLON 9
RegistriertCOLON Freitag 5. September 2008, 16:36
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

.net framework

Beitrag von Gecko » Donnerstag 25. September 2008, 21:29

Hallo,

ich würde mir gerne .net framework 3.0 installieren

habe aber dafür keinen platz

da kam mir die frage ob ich überhaupt dann noch die 1.0 und 2.0 brauche??

thx für eure antworten

Benutzeravatar
NXT-Inspire
Neuling
BeiträgeCOLON 27
RegistriertCOLON Samstag 23. August 2008, 21:29
WohnortCOLON Neumünster
CONTACTCOLON

Re: .net framework

Beitrag von NXT-Inspire » Donnerstag 25. September 2008, 21:37

Hi,
ich würde dann gleich das .NET Framework 3.5 installieren ;) Theoretisch musst du dann auch nicht mehr ältere .NET-Versionen installiert haben. Da Version 3.5 bzw. 3.0 lediglich "Erweiterungen" (WPF etc.) von Version 2 sind, werden Anwendungen, die das .NET 2 Framwork voraussetzen, auf jeden Fall laufen. Lediglich mit Anwendungen des 1er Frameworks KANN es Probleme geben, muss es aber nicht. Wenn dein Platz so knapp ist, würde ich das 1er und 2er Framework deinstallieren und das 3.5er Framework installieren.

Benutzeravatar
k0k0
Power User
BeiträgeCOLON 1091
RegistriertCOLON Mittwoch 2. Juli 2008, 09:55
WohnortCOLON Graz
CONTACTCOLON

Re: .net framework

Beitrag von k0k0 » Donnerstag 25. September 2008, 21:42

Diese Frage taucht in unzähligen, auch MS-internen Foren immer wieder auf und kann leider nur mit JEIN beantwortet werden! Das hängt ganz von Deinen Programmen ab. Manche, von MS als wichtig angesehene Teile, wurden in die neueren .NetFrameWork-Versionen integriert, andere leider nicht oder zumindest in einer nicht kompatiblen Version. Nichts wirklich genaues weiß dazu nicht einmal MS selbst, so einen Sauhaufen haben die mit diesem VB-Nachfolger! :evil: Will man also zu allen bisherigen Versionen (1.0, 1.1, 2.0, 3.0 & 3.5) voll kompatibel sein, bedeutet das, fast 1 GB(!) :shock: auf den Computer kippen zu müssen! Vollkommen irre was die da abziehen, doch manchmal kommt man dem Zeug leider nicht aus. Und das wirklich Tragische daran ist, dass das ganze Zeug auch noch in den Windows-Ordner gekippt wird! :twisted:
Downloads zu Netbooks (wie den ASUS EeePCs, Acer Aspire One's) und vielem anderen
701 / 901(GO) / 1000HG(O) & Leeenux / WXP - 2 GiB RAM - 16 GB SDHC - Huawei E220 & EM770 / ZTE MF628

Benutzeravatar
Be
Premium User
BeiträgeCOLON 578
RegistriertCOLON Samstag 12. Januar 2008, 11:32
WohnortCOLON Leipzig
CONTACTCOLON

Re: .net framework

Beitrag von Be » Freitag 26. September 2008, 09:05

die version 2 find ich ja noch ganz sinnvoll, die wird von einigen programmen verwendet, aber wie siehts mit der 3.0 oder 3.5 aus? mich hat noch nie nen programm danach gefragt, dass es das braucht...
schwarz, 1GB ram, 8GB patriot, 160GB WD Passport, xp, VGA MOD, Taschen Mod ...rennt!
Mein Blog: Einfach Nur Be <- ganz interessant

Benutzeravatar
NXT-Inspire
Neuling
BeiträgeCOLON 27
RegistriertCOLON Samstag 23. August 2008, 21:29
WohnortCOLON Neumünster
CONTACTCOLON

Re: .net framework

Beitrag von NXT-Inspire » Freitag 26. September 2008, 09:59

Bin selbst .NET-Programmierer (zur Eigenwerbung: Ich programmiere damit einen RSS-Reader ;)) und programmiere in Version 2. Hat den Vorteil, dass Version 2 relativ weit verbreitet ist (bei Vista gleich dabei, bei XP oft anzutreffen und auch für 2000 verfügbar). Version 3 bzw. 3.5 erweitern ja das Framwork nur etwas (WPF etc). Ich persönlich brauche diesen ganzen "Schnickschnack" (noch) nicht. Dem Endanwender empfehle ich aber, gleich Version 3.5 zu installieren, weil damit ja auch die Software laufen sollte, die für das 2er Framework gedacht ist.

Aerostar
Neuling
BeiträgeCOLON 6
RegistriertCOLON Mittwoch 27. August 2008, 18:37
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: .net framework

Beitrag von Aerostar » Montag 29. September 2008, 15:36

Ich habe nur das Framework 1.1 und 2.0 auf meinem 901. Damit laufen in der Tat die meisten Anwendungen, z.B. Paint.NET, nLite etc. Und gerade wegen des Speicherplatzes, wie hier schon erwähnt wurde, würde ich nicht unbedingt mehr draufkippen, wenn man es eh nicht braucht. :)

BUTTON_POST_REPLY
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Zurück zu

Wer ist online?

Mitglieder in diesem Forum: 2 und 0 Gäste