Update problem mit offiziellen Xandros packeten?

BUTTON_POST_REPLY [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
jammet
Neuling
BeiträgeCOLON 30
RegistriertCOLON Dienstag 25. März 2008, 14:46
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Update problem mit offiziellen Xandros packeten?

Beitrag von jammet » Freitag 16. Mai 2008, 11:47

Ich benutze den Simple-Modus und habe den ASUS Update Manager gestartet. Neulich hatte ich damit die USB-Storage Updates eingespielt. Heute bietet mir der Update Manager ein Update für die Sprachsteuerung ein Update an, welche ich versucht habe aufzuspielen.

Ich bekomme eine Fehlermeldung die mich dazu auffordert 'sudo apt-get -f install' auszuführen. Das habe ich auch gemacht, aber das Probem besteht. Bitte schaut euch das an, und helft mir:

CodeCOLON Alles auswählen

/home/user> sudo apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Abhängigkeit werden korrigiert... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  usbstorageapplet-de-de usbstorageapplet-zh-cn
Die folgenden NEUEN Pakete werden installiert:
  usbstorageapplet-de-de usbstorageapplet-zh-cn
0 aktualisiert, 2 neu installiert, 0 zu entfernen und 174 nicht aktualisiert.
26 nicht vollständig installiert oder entfernt.
Es müssen 5934B Archive geholt werden.
Nach dem Auspacken werden 90,1kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
WARNUNG: Die folgenden Pakete können nicht authentifiziert werden!
  usbstorageapplet-de-de usbstorageapplet-zh-cn
Diese Pakete ohne Überprüfung installieren [j/N]? j
Hole:1 http://update.eeepc.asus.com p701/main usbstorageapplet-de-de 1.1.69-1 [2784B]
Hole:2 http://update.eeepc.asus.com p701/main usbstorageapplet-zh-cn 1.1.69-4 [3150B]
Es wurden 5934B in 1s geholt (5397B/s)
(Lese Datenbank ... 71153 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke usbstorageapplet-de-de (aus .../usbstorageapplet-de-de_1.1.69-1_i386.deb) ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/usbstorageapplet-de-de_1.1.69-1_i386.deb (--unpack):
 Versuche, »/usr/share/apps/usbstorageapplet/messages/usbstorageapplet_de_DE.qm« zu überschreiben, welches auch in Paket asus-i18n-de-de ist
Entpacke usbstorageapplet-zh-cn (aus .../usbstorageapplet-zh-cn_1.1.69-4_i386.deb) ...
+ DIVERTEDFILE=/usr/share/apps/usbstorageapplet/messages/usbstorageapplet_zh_CN.qm
+ '[' install = install -o install = upgrade ']'
+ '[' -f /usr/share/apps/usbstorageapplet/messages/usbstorageapplet_zh_CN.qm ']'
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/usbstorageapplet-de-de_1.1.69-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
/home/user>                          

CodeCOLON Alles auswählen

/var/cache/apt/archives> ls -l
insgesamt 12
-rw-r----- 1 root root    0 2008-05-16 12:43 lock
drwxr-xr-x 2 root root 4096 2008-05-16 12:44 partial/
-rw-r--r-- 1 root root 2784 2008-05-07 03:21 usbstorageapplet-de-de_1.1.69-1_i386.deb
-rw-r--r-- 1 root root 3150 2008-05-10 04:01 usbstorageapplet-zh-cn_1.1.69-4_i386.deb
/var/cache/apt/archives>

Benutzeravatar
vofiwg
Power User
BeiträgeCOLON 2079
RegistriertCOLON Donnerstag 22. November 2007, 19:36
CONTACTCOLON

Re: Update problem mit offiziellen Xandros packeten?

Beitrag von vofiwg » Sonntag 18. Mai 2008, 17:06

Du kannst mal folgendes probieren:

CodeCOLON Alles auswählen

sudo apt-get --force-yes upgrade
Das sollte die vorhandene Datei überschreiben. Es kann jedoch sein, dass bei einem weiteren Update der Fehler wieder auftritt. Dann ist der Parameter --force-yes wieder anzuwenden.

vofiwg
Meine Tipps und Hinweise gibt es unter Ausschluss jeglicher Gewährleistung aber mit ganz dollem Daumendrücken. ;)

jammet
Neuling
BeiträgeCOLON 30
RegistriertCOLON Dienstag 25. März 2008, 14:46
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Update problem mit offiziellen Xandros packeten?

Beitrag von jammet » Montag 19. Mai 2008, 01:45

Das funktioniert leider nicht, aber wenn man

dpkg --force-overwrite <packet>

benutzt klappt es. Danach tut apt-get auch wieder problemlos weiter. Aber wie du ja beschrieben hast, eventuell muß danach irgendwann wieder nachgeholfen werden.

Ich frage mich aber warum ich wohl der einzige mit dem Problem war, obwohl hier 2 offizielle Packete miteinander kollidierten.

Das erste enthält Deutsche Spache für eine Reihe von Programmen, das zweite Paket war gerademal 3k groß und ersetzte gerade mal eine dieser Dateien. Seit wann macht man das auf diese Art und Weise, anstatt einfach eine neuere Version von Paket 1 rauszubringen?

Benutzeravatar
vofiwg
Power User
BeiträgeCOLON 2079
RegistriertCOLON Donnerstag 22. November 2007, 19:36
CONTACTCOLON

Re: Update problem mit offiziellen Xandros packeten?

Beitrag von vofiwg » Montag 19. Mai 2008, 04:16

jammet hat geschriebenCOLON Ich frage mich aber warum ich wohl der einzige mit dem Problem war, obwohl hier 2 offizielle Packete miteinander kollidierten.

Das erste enthält Deutsche Spache für eine Reihe von Programmen, das zweite Paket war gerademal 3k groß und ersetzte gerade mal eine dieser Dateien. Seit wann macht man das auf diese Art und Weise, anstatt einfach eine neuere Version von Paket 1 rauszubringen?
1. Du bist nicht der Einzige.

2. Asus macht halt so was. ;) Keine ahnung, was die sich dabei denken.

vofiwg
Meine Tipps und Hinweise gibt es unter Ausschluss jeglicher Gewährleistung aber mit ganz dollem Daumendrücken. ;)

Benutzeravatar
rob
Premium User
BeiträgeCOLON 634
RegistriertCOLON Samstag 17. November 2007, 22:41
CONTACTCOLON

Re: Update problem mit offiziellen Xandros packeten?

Beitrag von rob » Donnerstag 22. Mai 2008, 08:22

Hi

Der Fehler kommt nur wenn in synaptic defekte Pakete sind.Wenn man sie reparieren lässt klappt es wieder. :D

qwertzu
Neuling
BeiträgeCOLON 11
RegistriertCOLON Dienstag 6. November 2007, 23:45
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Update problem mit offiziellen Xandros packeten?

Beitrag von qwertzu » Donnerstag 22. Mai 2008, 15:22

Ich hatte gerade das selbe Problem wie jammet, konnte das Problem aber nicht wie oben beschrieben mit dpkg --force-overwrite lösen, da -overwrite aus irgendeinem Grund nicht als "Ding" akzeptiert wurde (keine Ahnung, warum das "Ding" heißt, so ist es aber in --force-help beschrieben). Keine Ahnung, was ich falsch gemacht habe.

Jedenfalls konnte ich nach einigen Versuchen mit

sudo apt-get remove asus-usbstorageapplet-update-2

wieder Ordnung schaffen. Sicherheitshalber habe ich danach noch ein
sudo apt-get -f install
gemacht (ich bezweifle, dass das einen Sinn hatte, aber "nutzts nix, schads nix"). Dann war die Paketverwaltung wieder in Ordnung, und ich konnte weitere Aktualisierungen auch wieder über die Softwareverwaltung durchführen. Das Update des usbstorageapplet rühr ich aber sicherheitshalber nicht mehr an.

Das ist jetzt zugegebenermaßen eine Beschreibung, aus der meine Unkenntnis dessen, was ich gemacht habe, nicht übersehbar ist. Aber vielleicht hilft sie ja der einen oder dem anderen weiter.

ZeroGravity3
BeiträgeCOLON 3
RegistriertCOLON Sonntag 25. Mai 2008, 19:09
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Update problem mit offiziellen Xandros packeten?

Beitrag von ZeroGravity3 » Sonntag 25. Mai 2008, 19:30

qwertzu hat geschriebenCOLONIch hatte gerade das selbe Problem wie jammet, konnte das Problem aber nicht wie oben beschrieben mit dpkg --force-overwrite lösen, da -overwrite aus irgendeinem Grund nicht als "Ding" akzeptiert wurde (keine Ahnung, warum das "Ding" heißt, so ist es aber in --force-help beschrieben). Keine Ahnung, was ich falsch gemacht habe.

Jedenfalls konnte ich nach einigen Versuchen mit

sudo apt-get remove asus-usbstorageapplet-update-2

wieder Ordnung schaffen. Sicherheitshalber habe ich danach noch ein
sudo apt-get -f install
gemacht (ich bezweifle, dass das einen Sinn hatte, aber "nutzts nix, schads nix"). Dann war die Paketverwaltung wieder in Ordnung, und ich konnte weitere Aktualisierungen auch wieder über die Softwareverwaltung durchführen. Das Update des usbstorageapplet rühr ich aber sicherheitshalber nicht mehr an.

Das ist jetzt zugegebenermaßen eine Beschreibung, aus der meine Unkenntnis dessen, was ich gemacht habe, nicht übersehbar ist. Aber vielleicht hilft sie ja der einen oder dem anderen weiter.

Mir hat die Beschreibung geholfen, vielen Dank.

Ich habe heute mein System auf Werkseinstellungen zurückgesetzt und wollte mit der Software-Verwaltung diverse Updates installieren.
Nach dem USB-Update war keine weitere Installation anderer Updates möglich.
Zuerst habe ich versucht mittels synaptic die Pakete zu reparieren, welches ich dann beendete, weil es mit Fehlermeldung abbrach.
Daraufhin habe ich mit "sudo apt-get remove asus-usbstorageapplet-update-2" den "Installationauftrag" und das Paket entfernt.
Danach hat "sudo apt-get -f install" nichts mehr in der Liste zur Installation angezeigt und die restlichen Updates ließen sich über die Software-Verwaltung installieren.

In der Software-Verwaltung (Karteikarte / Reiter "Spielen") bekomme ich auch den Mediaplayer (MPlayer) zur Installation angeboten, jedoch bricht die Installation mit der Fehlermeldung "Broken packages" ab, Synaptic zeigt aber keine Fehler an.

KSTC
Neuling
BeiträgeCOLON 33
RegistriertCOLON Dienstag 26. Februar 2008, 15:06
CONTACTCOLON

Re: Update problem mit offiziellen Xandros packeten?

Beitrag von KSTC » Sonntag 14. September 2008, 00:57

Hi,

ich habe das gleiche Problem. Gibt es schon eine neue Lösung,oder muss das USB Storage Update unbedingt gelöscht werden?

BUTTON_POST_REPLY
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Zurück zu

Wer ist online?

Mitglieder in diesem Forum: 1 und 0 Gäste