Probleme nach Einrichtung UMTS-Stick

BUTTON_POST_REPLY [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
202sim
Neuling
BeiträgeCOLON 5
RegistriertCOLON Mittwoch 18. Juni 2008, 20:31
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Probleme nach Einrichtung UMTS-Stick

Beitrag von 202sim » Freitag 3. Oktober 2008, 13:21

Hallo miteinander!

Ich habe einen eee 701 mit einem schwarzen web'n'walk-Stick. Seit ich diesen installiert habe (Anleitung auch hier im Forum vorhanden) gelingt es mir nicht mehr mittels w-Lan oder Ethernet zu surfen. Skype hingegen funktioniert problemlos. Ich kann auch bis zu meinem DSL-Router pingen, nur nicht darüber hinaus. Probleme mit dem MAC-Adressfilter können ausgeschlossen werden, da dieses schon funktioniert hat. Hat jemand eine Idee bzw. eine Lösung?

Danke und Gruß

202sim

Benutzeravatar
flux
ENTWICKLER
BeiträgeCOLON 355
RegistriertCOLON Donnerstag 20. März 2008, 16:38
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Probleme nach Einrichtung UMTS-Stick

Beitrag von flux » Freitag 3. Oktober 2008, 13:26

Es könnte sein, dass dir die für die UMTS-Verbindung zuständige Software einen eigenen DNS-Eintrag in /etc/resolv.conf macht und nach dem Beenden nicht mehr entfernt, bzw. die alten Einträge für LAN/WLAN nicht mehr herstellt. Damit würde dein LAN und WLAN nicht mehr über den Router hinaus funktionieren.

Nur eine Idee, ich selber nutze kein Xandros.

flux.

202sim
Neuling
BeiträgeCOLON 5
RegistriertCOLON Mittwoch 18. Juni 2008, 20:31
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Probleme nach Einrichtung UMTS-Stick

Beitrag von 202sim » Freitag 3. Oktober 2008, 13:47

Wie kann man dieses aktualisieren? In meiner /etc/resolve.conf stehen die DNS-Server der UMTS-Verbindung. Unter /etc/resolveconf/>run gibt es eine resolve.conf mit den Daten meiner DSL/WLAN-Verbindung. Wie kriege ich den das Gerät überredet, die richtig Config zu nutzen.

Vielen Dank und Gruß

202sim

Benutzeravatar
flux
ENTWICKLER
BeiträgeCOLON 355
RegistriertCOLON Donnerstag 20. März 2008, 16:38
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Probleme nach Einrichtung UMTS-Stick

Beitrag von flux » Freitag 3. Oktober 2008, 13:56

Das sollte das System eigentlich automatisch machen!

Läuft da in Xandros nicht ein Dämon, der die DNS der aktuellen Verbindung ausliest und in die /etc/resolv.conf einträgt? Kannst du den Dienst starten?

flux.

202sim
Neuling
BeiträgeCOLON 5
RegistriertCOLON Mittwoch 18. Juni 2008, 20:31
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Probleme nach Einrichtung UMTS-Stick

Beitrag von 202sim » Freitag 3. Oktober 2008, 20:18

Problem gelöst.

Man muss immer die UMTS-Verbindung manuell trennen. Ansonsten bleiben die Einträge in der /etc/resolv.conf dauerhaft. Ich habe zur Lösung folgendes unternommen:
sudo rm /etc/resolv.conf
sudo ln -s /etc/resolvconf/run/resolv.conf /etc/resolv.conf

Danach funktioniert sowohl WLAN als auch UMTS. Sofern man immer hübsch manuell die UMTS-Verbindung trennt :wink:

Danke für die Hilfe.

Gruß 202sim

Benutzeravatar
boehmling
Profi
BeiträgeCOLON 230
RegistriertCOLON Donnerstag 19. Juni 2008, 10:50
WohnortCOLON Weischlitz
CONTACTCOLON

Re: Probleme nach Einrichtung UMTS-Stick

Beitrag von boehmling » Samstag 4. Oktober 2008, 08:56

interessant, dass du den schwarzen stick unter linux zum laufen bekommen hast, normalerweise sollte der da garnicht funktionieren, deswegen kam ja der weiße dann raus.
EEE 1000H in schwarz - 2048 MB RAM - Windows XP SP3
T-Mobile Web'n'Walk Stick IV mit UMTS-Flat - Genius Traveller 525 Laser Maus - diverse USB-Sticks - USB-Laptop-Lampe

202sim
Neuling
BeiträgeCOLON 5
RegistriertCOLON Mittwoch 18. Juni 2008, 20:31
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Probleme nach Einrichtung UMTS-Stick

Beitrag von 202sim » Samstag 4. Oktober 2008, 12:28

Ich habe beides im Bundle gekauft und eine Anleitung dazu bekommen. Diese geistert auch hier im Forum rum. Habe ich aber auf die Rasche nicht gefunden. Funktioniert jedenfalls super. Vorallem nachdem mein WLAN-Problem gelöst ist. :D
Gruß 202sim

BUTTON_POST_REPLY
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Zurück zu

Wer ist online?

Mitglieder in diesem Forum: 1 und 0 Gäste