Grub nach Ubuntu Installation wie Entfernen

BUTTON_POST_REPLY
b.rasi
BeiträgeCOLON 2
RegistriertCOLON Montag 1. November 2010, 21:33

Grub nach Ubuntu Installation wie Entfernen

Beitrag von b.rasi » Montag 1. November 2010, 21:35

Hallo,

ich bin blutiger Anfänger mit Linux und hoffe mir kann jemand helfen.

Ich habe versucht auf meinem EEE 701 Ubuntu 10.10 Netbook Edition per Live USB Stick auf der SD-Karte zu installieren.

Bei der Installation gabe es keine Fehlermeldung. Wenn ich jetzt der Grub Startet und ich Ubuntu auswähle kommt nach einiger Zeit die Fehlermeldung:
Kernel panic – not syncing VFS: Unable to mount root fs on unknown-block (0,0)

Wie bekomme ich Ubuntu zum laufen?

Kann ich den Grub irgendwie wieder löschen, so das ich beim Booten mit der ESC-Taste auswählen kann, ob von der HDD oder der SD-Karte gebootet wird?

Wenn ich die SD-Karte entferne und boote bekomme ich die Fehlermeldung:

Error: no such device
Grub rescue

Vielen Dank schonmal im voraus

b.rasi

Benutzeravatar
blackice
Power User
BeiträgeCOLON 1079
RegistriertCOLON Dienstag 11. November 2008, 21:46

Re: Grub nach Ubuntu Installation wie Entfernen

Beitrag von blackice » Montag 1. November 2010, 22:22

b.rasi hat geschriebenCOLONIch habe versucht auf meinem EEE 701 Ubuntu 10.10 Netbook Edition per Live USB Stick auf der SD-Karte zu installieren.
Keine schlechte Idee wenn man bedenkt, dass auf dem Gerät bisher Xandros läuft. Ich würde es gleich auf die interne SSD installieren.
b.rasi hat geschriebenCOLONWenn ich jetzt der Grub Startet und ich Ubuntu auswähle kommt nach einiger Zeit die Fehlermeldung:
Kernel panic – not syncing VFS: Unable to mount root fs on unknown-block (0,0)
Kannst du mal bitte den Inhalt des root-Verzeichnisses deiner Ubuntu-Installation sowie die dort befindliche Datei /etc/grub/grub.conf posten?
b.rasi hat geschriebenCOLONKann ich den Grub irgendwie wieder löschen, so das ich beim Booten mit der ESC-Taste auswählen kann, ob von der HDD oder der SD-Karte gebootet wird?
Ich weiß nicht wie es beim 701 ist, aber beim 901 ist das eine Frage des BIOS. Ein Bootmanager ist da also noch gar nicht geladen und es sollte funktionieren egal in welchem Zustand Grub gerade ist.
Modell: EEE 901 - OS: wattOS beta1 (array.org-kernel)/Slax 6.0.7 (alsa 1.0.18a) - RAM: 2GB (MDT 667MHz) - Zubehör: Akku 8800mAh, SDHC-Card Sandisk UltraII plus USB 8GB

Benutzeravatar
Lorag
Power User
BeiträgeCOLON 1202
RegistriertCOLON Dienstag 18. März 2008, 23:33

Re: Grub nach Ubuntu Installation wie Entfernen

Beitrag von Lorag » Donnerstag 4. November 2010, 11:45

Kann es sein, dass du bei der Installation Grub auf die interne SSD gepackt hast und nicht auf die SD-Card? Wenn ja, war das falsch bzw. sollte nur so sein, wenn du auch Ubuntu auf die SSD packst.

b.rasi
BeiträgeCOLON 2
RegistriertCOLON Montag 1. November 2010, 21:33

Re: Grub nach Ubuntu Installation wie Entfernen

Beitrag von b.rasi » Freitag 5. November 2010, 20:56

Hallo,

der Grub sollte auf die SSD. Ich hatte bei der Installation leider keine Auswahlmöglichkeit.

Ich habe das Problem aber mittlerweile für das erst gelöst. Nach dem ich beim vielen herumprobieren den MRB gelöscht habe, habe ich mit der Recovery-CD Xandros neu auf gespielt. Jetzt läuft alles wieder wie früher.

Trotzdem vielen Dank

Gruß

b.rasi

Benutzeravatar
Sedge
Premium User
BeiträgeCOLON 833
RegistriertCOLON Sonntag 22. März 2009, 12:45

Re: Grub nach Ubuntu Installation wie Entfernen

Beitrag von Sedge » Samstag 6. November 2010, 08:55

b.rasi hat geschriebenCOLONIch hatte bei der Installation leider keine Auswahlmöglichkeit.
Doch, hattest du: http://wiki.ubuntuusers.de/Ubuntu_Insta ... Bootloader
/ Asus EeePC 1000H / 2 GB / Win 7 Ultimate / Ubuntu 10.04 /
/ Intel Core i5-760 / HD 5770 / 4 GB / Win 7 Professional /
/ Samsung Nexus S / Android 2.3.4 /

Dropbox - 2 GB + 250 MB *extra* für dich und mich!

Benutzeravatar
Lorag
Power User
BeiträgeCOLON 1202
RegistriertCOLON Dienstag 18. März 2008, 23:33

Re: Grub nach Ubuntu Installation wie Entfernen

Beitrag von Lorag » Samstag 6. November 2010, 13:33

Sedge hat recht, aber ich geb zu, dass das etwas tief drin versteckt ist.

Benutzeravatar
blackice
Power User
BeiträgeCOLON 1079
RegistriertCOLON Dienstag 11. November 2008, 21:46

Re: Grub nach Ubuntu Installation wie Entfernen

Beitrag von blackice » Samstag 6. November 2010, 19:02

b.rasi hat geschriebenCOLONNach dem ich beim vielen herumprobieren den MRB gelöscht habe, habe ich mit der Recovery-CD Xandros neu auf gespielt. Jetzt läuft alles wieder wie früher.
Keine gute Wahl in Anbetracht der vielen Sicherheitsprobleme von Xandros.
Modell: EEE 901 - OS: wattOS beta1 (array.org-kernel)/Slax 6.0.7 (alsa 1.0.18a) - RAM: 2GB (MDT 667MHz) - Zubehör: Akku 8800mAh, SDHC-Card Sandisk UltraII plus USB 8GB

Benutzeravatar
try
Premium User
BeiträgeCOLON 976
RegistriertCOLON Samstag 25. April 2009, 16:40

Re: Grub nach Ubuntu Installation wie Entfernen

Beitrag von try » Samstag 6. November 2010, 19:33

Jupp - Du magst ja recht haben, nur bekehren sollte man die Leute auch nicht unbedingt. :wink:

Aber -

Da die Diskussion über Xandros nicht abreissen will, hier jetzt mal ein Versuch der Kanalisierung:
http://www.eee-pc.de/board/viewtopic.ph ... 800#p65800

Gruss - try
-- 701 4G --- 1GiB RAM - Ubuntu 10.10 Netbook
- 1000 H ---- 2GiB RAM - XP (- immer noch ) ----
--------- Any Mistakes ? --> A t c t R ! <---------

BUTTON_POST_REPLY

Zurück zu

Wer ist online?

Mitglieder in diesem Forum: 3 und 0 Gäste